为什么你不能在 MySQL 3.x 版本上安装 Joomla 1.5.23

Joomla 1.5.23 修改了创建 Joomla 数据库的 SQL 查询脚本。

这些脚本仅在您创建新的 Joomla 按照数据库时候有效,而仅仅是第一次安装的时候有效。

这些修改的 SQL 脚本不能在得到老版的 MySQL 3.x 支持。

MySQL 3.x 版本已经发行超过了 8 年,对很多用户来说,这并不是什么问题,因为越来越多的用户已经不再使用 MySQL 3.X 版本了。

如果你尝试安装 Joomla 1.5.23 的时候,安装程序报不支持 MySQL 4.X 的异常,下面的一些链接能够提供解决方案供您参考。

[list=1]
[]使用 1.5.22 的 zip 归档文件进行完全安装。
[
]在安装完成后,使用1.5.22 升级到 1.5.23 zip 归档文件进行升级。
[/list]

在完成上面的步骤后,您应该可以运行 Joomla 1.5.23 了。