Maven 的 Maven Compiler Plugin 插件

当前 Maven Compiler Plugin 这个插件的版本为 3.10.1

你可以使用最新的版本。

我们今天主要说一下这个插件中 --release 参数

这个插件的配置方法如下:

<?xml version="1.0" encoding="UTF-8"?>
<plugin>
   <groupId>org.apache.maven.plugins</groupId>
   <artifactId>maven-compiler-plugin</artifactId>
   <version>3.10.1</version>
   <configuration>
      <release>11</release>
   </configuration>
</plugin>

从 JDK 9+ 版本以后,添加了一个 --release 参数来告诉 Maven 在编译的时候使用的是那个 JDK 的版本。

通常这个参数了决定了你在 IntelliJ IDEA 中导入项目后为你设置的 JDK 编译级别。

以前,我们通常还需要添加 11 和 11 这 2 个配置参数在里面。

当你设置了 --release 参数后,上面 2 个参数就不再需要了。

这是因为 --release 设置后,将会自动把 11 和 11 2 个参数设置为 --release 相同的版本。

因此上面的 2 行代码就是多余的了,并不需要。