Gem install jekyll 提示版本过低

提示版本过低:

Fetching: public_suffix-4.0.6.gem (100%)
ERROR:  Error installing jekyll:
	public_suffix requires Ruby version >= 2.3.

解决办法

需要依次执行下面的命令:

导入需要执行的 Key

gpg --keyserver hkp://keys.gnupg.net --recv-keys 409B6B1796C275462A1703113804BB82D39DC0E3 7D2BAF1CF37B13E2069D6956105BD0E739499BDB

运行安装命令

\curl -sSL https://get.rvm.io | bash -s stable

启用 RVM

source /etc/profile.d/rvm.sh

安装 Ruby

rvm install ruby

当完成上面的命令后,你可以查看 ruby 的版本。

[[email protected] ~]# ruby -v
ruby 2.7.0p0 (2019-12-25 revision 647ee6f091) [x86_64-linux]

至此 Ruby 更新成功。