Docsify 安装

首先查看你的本地命令行中是否安装了 Docsify。

运行 docsify -v

如果显示:

C:\WorkDir\Repository\cwiki-us-docs\spring-boot-docs>docsify -v
'docsify' is not recognized as an internal or external command,
operable program or batch file.

就说明你的系统中没有安装。

如果你已经装了 npm 或者 python 的话,

运行命令:

npm i docsify-cli -g

进行安装。

计算机将会输出:

C:\WorkDir\Repository\cwiki-us-docs\spring-boot-docs>npm i docsify-cli -g
C:\Users\yhu\AppData\Roaming\npm\docsify -> C:\Users\yhu\AppData\Roaming\npm\node_modules\docsify-cli\bin\docsify

> [email protected] postinstall C:\Users\yhu\AppData\Roaming\npm\node_modules\docsify-cli\node_modules\docsify
> opencollective-postinstall

Thank you for using docsify!
If you rely on this package, please consider supporting our open collective:
> https://opencollective.com/docsify/donate

npm WARN optional SKIPPING OPTIONAL DEPENDENCY: [email protected]~2.1.2 (node_modules\docsify-cli\node_modules\chokidar\node_modules\fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for [email protected]: wanted {"os":"darwin","arch":"any"} (current: {"os":"win32","arch":"x64"})

+ [email protected]
added 204 packages from 90 contributors in 16.035s

再次运行命令查看版本。

如果能够显示版本号的话,就说明已经安装成功了。

C:\WorkDir\Repository\cwiki-us-docs\spring-boot-docs>docsify -v

docsify-cli version:
  4.4.1