Confluence 6 新安装配置数据库字符集编码

Confluence 和你的数据库必须配置使用相同的字符集。
Confluence 使用 UTF-8 字符集编码,所以你的数据库也必须配置为使用 UTF-8 (或者与 UTF-8 相同的编码,例如在 Oracle 中使用的 AL32UTF8 编码)。

当你在第一次安装 Confluence 的时候,你需要考虑下面的的几个位置配置使用不同的字符集:

  • 当你创建数据库的时候。
  • 当你使用 JDBC 字符串连接数据库时候配置的连接字符串,或者是你使用的数据源(如果你在安装 Confluence 的时候使用的是简单配置模式,安装向导将会自动帮你配置)。

Confluence 安装向导将会在安装的时候对你的字符集进行校验,如果出现问题,安装向导将会对你弹出警告信息。这个能够保证让你在后续的配置和运行中不会出现问题,相对后期进行调整,现在就把问题解决要容易得多,当你有数据在数据库中进行存储的时候再进行字符集调整就会比较麻烦了。
针对 Confluence 支持的每一个数据库如何进行字符集调整的指南如下,当你在创建数据库的时候请参考下面的指南: