Archiva 运行时提示 JAXBException 错误

有关错误的信息如下:

问题和解决

有关这个问题是因为你的服务器上可能使用了 JDK 11 的版本。

但是最新的 Archiva 只能够支持 1.8 的版本。

如果你的服务器缺包的话,就会出现上面的错误。

你可以尝试使用 Archiva 自己进行编译,或者部署到 1.8 的 JDK 版本上,或者等到 Archiva 3.0 的版本后再开始用吧。

我们看到 Git 的代码库中,有关 Archiva 正在尝试使用 11 的 JDK 版本进行编译。

但是,具体需要什么时候才能用,就不太清楚了。

1 Like

不得不吐槽下,Archiva 的升级太慢了。

可能主要原因是很多公司都会选择商业版本的吧。