Apache POI Strict OOXML isn't currently 错误

在处理文件的时候 POI 提示错误:

org.apache.poi.ooxml.POIXMLException: Strict OOXML isn't currently supported, please see bug #57699

	at org.apache.poi.ooxml.POIXMLDocumentPart.getPartFromOPCPackage(POIXMLDocumentPart.java:779)
	at org.apache.poi.ooxml.POIXMLDocumentPart.<init>(POIXMLDocumentPart.java:175)
	at org.apache.poi.ooxml.POIXMLDocumentPart.<init>(POIXMLDocumentPart.java:165)
	at org.apache.poi.ooxml.POIXMLDocument.<init>(POIXMLDocument.java:61)
	at org.apache.poi.xssf.usermodel.XSSFWorkbook.<init>(XSSFWorkbook.java:282)

这是因为你的 Excel 保存的格式版本为 Strict Open XML 格式。

你需要将这个文件保存为 Excel WorkBook 格式才能够被 POI 读取。

针对这个问题暂时没有太多的解决办法,你只能让用户保存为 Excel WorkBook 格式才能让 Apache POI 处理。